Резервный канал на Cisco с ip sla

Имеется:

2 интернет провайдера
2 сетки ip адресов
IOS c2800nm-adventerprisek9-mz.124-22.T.bin
4 интерфейса FastEthernet

привожу только команды необходимые для работы данного метода.

настраиваем интерфейсы

interface FastEthernet0/1
description PROV1external
ip address 110.110.110.110 255.255.255.0
ip nat outside

interface FastEthernet0/2
description PROV2external
ip address 220.220.220.220 255.255.255.0
ip nat outside

interface FastEthernet0/3
description PROV1internal
ip address 111.111.111.111 255.255.255.0
ip nat inside

interface FastEthernet0/4
description PROV2internal
ip address 222.222.222.221 255.255.255.0
ip nat inside

создаем ip sla выбрав предварительно ip в инете или из своих удаленных офисов для jitter-а, например по одному sla проверяем через yandex по другому через rambler на проверочном ip должен быть включен cisco cdp

ip sla 1
icmp-jitter 213.180.213.49 source-ip 110.110.110.110
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-jitter 81.19.68.6 source-ip 220.220.220.220
ip sla schedule 2 life forever start-time now

создаем следящие track за ip sla

track 1 ip sla 1 reachability

track 2 ip sla 2 reachability

вводим маршрутизацию с метрикой предпочтения

ip route 0.0.0.0 0.0.0.0 110.110.110.112 50 track 1
ip route 0.0.0.0 0.0.0.0 220.220.220.222 100 track 2

создаем access-list-ы при помощи которых будем управлять трафиком в сторону провайдеров, те ip которые при падении одного провайдера не должны идти NAT-ом через другого провайдера вписываем в виде deny

ip access-list standard PROV1internal
deny   111.111.111.115
permit 111.111.111.0 0.0.0.255
ip access-list standard PROV2internal
deny   222.222.222.225
permit 222.222.222.0 0.0.0.255

создаем NAT и привязываем его к access-list-ам чтобы при переходе с одного провайдера на другой ip адреса отключившегося провайдера выходили в инет через NAT

ip nat inside source route-map PROV1internal interface FastEthernet0/0 overload
ip nat inside source route-map PROV2internal interface FastEthernet0/1 overload

создаем access-list-ы разрешающие сеткам двух провайдеров посылать друг друг другу пакеты.

access-list 100 permit ip 111.111.111.0 0.0.0.255 222.222.222.0 0.0.0.255
access-list 100 permit ip 222.222.222.0 0.0.0.255 111.111.111.0 0.0.0.255

создаем route-map-ы посредством которых будут регулироваться правила next-hope и разрешения на NAT

route-map PROV1 permit 10
match ip address PROV2internal
match interface FastEthernet0/0
!
route-map PROV2 permit 10
match ip address PROV1internal
match interface FastEthernet0/1
!
route-map PROV1+PROV2 deny 10
match ip address 100
!
route-map PROV1+PROV2 permit 20
match ip address PROV1
set ip next-hop 110.110.110.112
!
route-map PROV1+PROV2 permit 30
match ip address PROV2
set ip next-hop 220.220.220.222

Вроде вот так, не помню уже откуда брал статью, помню только что пришлось адаптировать под новую IOS, так как на старой не работало. Ну и на мой взгляд конфига получилась какая-то путанная, сам каждый раз на нее смотрю с первого взгляда не врубаюсь что куда и как пойдет, но зато конфига рабочая.

Запись опубликована в рубрике Router. Добавьте в закладки постоянную ссылку.